rt61 master mode kernel 2.6.24

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=4800

ice2000

18-05-2008 06:19:59

Hi everybody, I almost lost in space....!
I'm running Ubuntu Kernel 2.6.24 and my Wlan Card with rt61 chipset is running out of the box in mode "managed".
My problem ist that I would like to create an accesspoint.
I understood that your driver is used in that kernel version?!
I understood that the AP funktionallity just can be used with hostapd, correct?
I understood that I can not use a precompiled hostapd, because the most feature are off.
Which version of Hostapd do I need, and does someone know how to configure and compile under Ubuntu?
When I do a "make" I got millions of errors....! Which points me to that I do not have alle needed requirements. Any help would be appriciated.

Thanks shock

Bruce

23-06-2008 16:58:47

I managed to use an rt61 based card as an access point using kernel 2.6.24.7 and compat-wireless-2008-05-26 (i guess latest snapshot from rt2x00 should work as well)

First, you need to patch mac80211 to accept Master Mode, and then use hostapd to handle the mode.

This is how i did it (letting aside the kernel stuff)

- Decompress compat-wireless-2008-05-26
- edit compat-wireless-2008-05-26/net/mac80211/cfg.c
- In line 38 , just after the #endif added the following
case NL80211_IFTYPE_AP
return IEEE80211_IF_TYPE_AP;
case NL80211_IFTYPE_AP_VLAN
return IEEE80211_IF_TYPE_VLAN;
- compiled and installed the new mac80211 modules.

This will enable hostapd to set Master mode.

Then, compile and install a hostapd that supports nl80211 driver, and start it using this sample configuration (its minimal, no encryption)

interface=wlan0
driver=nl80211

logger_syslog=-1
logger_syslog_level=2
logger_stdout=1
logger_stdout_level=2
ssid=rt61pci
channel=7
hw_mode=g
macaddr_acl=0
auth_algs=1 # 802.11 Open System Authentication (no WEP)
eap_server=0
own_ip_addr=127.0.0.1
ctrl_interface=/var/run/hostapd
ctrl_interface_group=0



So far, im running an accesspoint using a rt61 based minipci card. (works fine on an Arilink 525W router, and on a laptop using fedora 7)



PS I'll try to make a more detailed howto. Ill update this post if i finish it.

jalbert

27-06-2008 15:52:51

Thanks for the post it was a big help.

I am using OpenWRT on the Airlink 525 (which is what I assume you are using). I'm having two problems.

The first is that when I use the Airlink router in master mode with no encryption using the configuration file in the previous post everything works fine except that if there is no activity between my laptop (Windows XP) and the router for about 15 seconds, the wifi connection is dropped. If I start a ping -t 192.168.1.1 for example the link stays connected and everything works fine.

The second is that I cannot get any encryption mode to work. The ssid is visible, but when I try to connect it does not work.

Can you give me some hints on what might be going wrong. Are you using OpenWrt? If yes what version of OpenWrt are you using?

Thanks