driver on Slackware 11

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=5081

hvn52

16-11-2008 19:43:55

Hi,

I recently purchased a PC-Card which (on Fedora 9) asks for rt2561.bin. Via the internet I found the Ralink website and the 2008_0723_RT61_Linux_STA_v1.1.2.2 driver. However, after compiling this on Slackware 11 running 2.4.33.3 kernel, I get this error on depmod -a

# modprobe rt61
/lib/modules/2.4.33.3/extra/rt61.o /lib/modules/2.4.33.3/extra/rt61.o unresolved symbol wext_notify_event_assoc
/lib/modules/2.4.33.3/extra/rt61.o
Hint You are trying to load a module without a GPL compatible license
and it has unresolved symbols. The module may be trying to access
GPLONLY symbols but the problem is more likely to be a coding or
user error. Contact the module supplier for assistance, only they
can help you.

/lib/modules/2.4.33.3/extra/rt61.o insmod /lib/modules/2.4.33.3/extra/rt61.o failed
/lib/modules/2.4.33.3/extra/rt61.o insmod rt61 failed
#

Do I have to use the Legacy driver from this website to overcome this or can this message be avoided by some other action?

Thanks.

IvD

16-11-2008 20:12:25

As mentioned here
as well as in various other places
We don't support drivers which are not released as part of this project. So either ask support on the Ralink website or use the drivers from our website.

(Really, why do I have to repeat this every time for every user...)

hvn52

16-11-2008 20:28:44

I did read that. So let me put it this way do you recommend the Ralink driver or the Legacy driver from here when using the older 2.4 kernel? BTW, if I read their site correctly, Ralink redirects to this site for help on the Linux driver.

Thank you.

Spy84464

17-11-2008 19:25:41

Hello,
we certainly recommend you to try our version of the driver. We do not support Ralink's releases at all, even if ours are based on them.

Regards,
Romain