SMP support committed to CVS

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=3677

Zi7

25-04-2007 05:52:59

I just committed to CVS a few patches that have resolved all SMP/preemption problems of legacy rt61 so far.

If i'm lucky, rt73 might now support SMP kernels.
Or perhaps i just broke the whole thing. ;)

Guys, it's time to boot your SMP kernels again!
Tests and reports welcome...

alex-it

25-04-2007 21:44:01

Bad news Kernel panic after testing last CVS... (

Ubuntu Feisty 7.04
Kernel 2.6.20-15-generic #2 SMP Sun Apr 15 073631 UTC 2007 i686 GNU/Linux
Device D-link dwl-g122 rev C1, usbid 07d13c03

The driver was working great before last commit...

Last line before hanging
"kernel panic - not syncing fatal exception in interrupt"

Here the screenshot of the last screen, with call trace
http//img75.imageshack.us/img75/9607/25042007pi2.jpg

Hope it helps ;)

Zi7

25-04-2007 21:46:47

Thanks for the report, i'll have a look into this. )

Zi7

25-04-2007 22:18:38

Hi,

Could you test the patch attached to this post [url19o1rfjj]http://rt2x00.serialmonkey.com/phpBB2/viewtopic.php?p=21905#21905[/url19o1rfjj]

alex-it

25-04-2007 22:28:54

Hi,

Could you test the patch attached to this post [url11vd4lzr]http://rt2x00.serialmonkey.com/phpBB2/viewtopic.php?p=21905#21905[/url11vd4lzr][/quote11vd4lzr]

Ok... but I have some problems applying the patch
[code11vd4lzr]#~/rt73/Module$ patch -i patch.txt
patching file mlme.c
Hunk #1 FAILED at 353.
1 out of 1 hunk FAILED -- saving rejects to file mlme.c.rej[/code11vd4lzr] ?

Zi7

25-04-2007 22:37:36

Sorry, i put the wrong patch. /
I fixed it. Should be the good one now...

alex-it

25-04-2007 22:52:36

after patching, i insert the module, but
[code3tma297j]FATAL: Error inserting rt73 (/lib/modules/2.6.20-15-generic/extra/rt73.ko): Unknown symbol in module, or unknown parameter (see dmesg)[/code3tma297j]

dmesg[code3tma297j]rt73: Unknown symbol MlmeWork[/code3tma297j]

Zi7

25-04-2007 22:58:53

Ok. P
Patch updated.

alex-it

26-04-2007 16:35:37

Patched again.... another kernel panic...

Screenshoot http//img338.imageshack.us/img338/2351/26042007sc9.jpg

Zi7

26-04-2007 16:43:22

CVS has been updated last night (it should work without patching).
Did you try the patch on yesterday's CVS or today's?

alex-it

26-04-2007 16:51:31

CVS has been updated last night (it should work without patching).
Did you try the patch on yesterday's CVS or today's?[/quote1f8a0cul]
I tried the patch on yesterday's CVS. I'm going to test the new one )
Thanks

alex-it

26-04-2007 17:21:26

Ok... today's CVS works great at the moment ! )

Thank you again...

defcon

08-10-2007 15:19:44

ok wep works fine, but the driver causes a complete system lockup with wpa enabled while connecting to wpa networks, I have a P4 hyperthread enabled, I think this could be the issue, although when I upgraded from feisty to gutsy
Linux ion 2.6.22-13-generic #1 SMP Thu Oct 4 171844 GMT 2007 i686 GNU/Linux

Spy84464

08-10-2007 18:44:26

Hello,
Please create a new thread and post all debugging information, as described in the TESTING file coming with the driver. Make sure you mention which driver you're using, and use the very latest version. Also, gutsy likely ship some driver which may conflict with the one you could have installed yourself, unless you took care of that already.

Regards,
Romain