solution: hp pavilliion s3100n

Live forum:


25-09-2007 03:05:55

I have my built-in wireless working the way I want now, so I'm posting a summary.

I have an HP Pavillion S3100N which is an amd64 SMP machine, running Debian testing/lenny.

To figure out which driver I needed I looked up the device's FCC ID at https// ... Search.cfm I found the FCC ID inside the case printed on a sticker on the wireless board. This lead me to a user manual with the following statement
[quote3aqf2xe5]Main chipset
Baseband / MAC Ralink RT2571WF
RF Ralink RT2528L
Initially that lead me to believe I needed the rt2570 driver, but that is not the case. Digging further, [code3aqf2xe5]lsusb[/code3aqf2xe5] reports
[quote3aqf2xe5]Bus 002 Device 003 ID 15a90004
which can be looked up in the driver source file rtmp_def.h ( http// ... iew=markup ) as
The developers here are best able to support the current version of the drivers, so get it from http//

I had initially tried to build the [code3aqf2xe5]rt2570-source[/code3aqf2xe5] package from debian which set me up with the proper build environment (compiler, linux headers, etc.) so a [code3aqf2xe5]make[/code3aqf2xe5] in the Module directory worked fine. [code3aqf2xe5]make install[/code3aqf2xe5] caused my machine's video to be unusable [quote3aqf2xe5]Sync out of range error[/quote3aqf2xe5] from my monitor. So I can't recommend that, since my work-around was to rebuild the machine.

After the make, I copied rt73.bin to /lib/firmware and copied rt73.ko to /lib/modules/2.6.21-2-amd64/kernel/net/wireless. When I tried to load the driver at this point I got an error about missing symbols.

[quote3aqf2xe5]insmod error inserting 'rt73.ko' -1 Unknown symbol in module [/quote3aqf2xe5]

I had to load the firmware loader first with [code3aqf2xe5]modprobe firmware_class[/code3aqf2xe5] then the [code3aqf2xe5]insmod rt73.ko[/code3aqf2xe5] worked, as you can see by doing a [code3aqf2xe5]ifconfig -a[/code3aqf2xe5] Then I did a [code3aqf2xe5]depmod -a[/code3aqf2xe5] At this point I think the module will load automatically if you reboot.

To get the interface to come up and configure automatically at boot, I added the following to [code3aqf2xe5]/etc/network/interfaces[/code3aqf2xe5]

[quote3aqf2xe5]# Wireless
auto wlan0
iface wlan0 inet dhcp
pre-up ifconfig wlan0 up
pre-up iwconfig wlan0 essid blue32
pre-up iwconfig wlan0 mode Managed
pre-up iwpriv wlan0 set AuthMode=WPAPSK
pre-up iwpriv wlan0 set EncrypType=TKIP
pre-up iwpriv wlan0 set WPAPSK='passwd'

Note that this means you need the [code3aqf2xe5]wireless-tools[/code3aqf2xe5] Debian package, but *not* the [code3aqf2xe5]wpasupplicant[/code3aqf2xe5] package.

Thanks to IvD who gave me excellent support (5 posts!) on a Saturday and Sunday.


21-10-2007 17:11:41

Hi aburry,

I cannot get this to work for what ever reason. I too am running a s3100n and this driver refuses to load. I'm still fairly new to this, but am learning fast.

I'm not sure about the command

[quote27wzv8r7] had to load the firmware loader first with

[code27wzv8r7]modprobe firmware_class[/code27wzv8r7][/quote27wzv8r7]

I keep getting an error message

FATAL: Module firmware_class not found.[/code27wzv8r7]

is firmware_class suppose to be a filename perhaps? I'm very new to this.

I'm running Ubuntu 7.10 (Gutsy Gibbon), but the 32-bit for now.

Thanks for any help you can provide me.



21-10-2007 18:12:31

Correction, I have succeeded! Told you I was a fast learner. I'm guessing in my previous attempts to load the rt73 driver that I had conflicting drivers maybe? Again, being new, this is just a guess. But it worked. I did edit /etc/network/interfaces, but decided against the pre-up options. Everything seems to be working good now. Thanks for your guide by the way, but a little elaboration on the firmware_class wouldn't be a bad idea for us newbies.

Thanks again,