Must set ESSID _and_ MAC address of AP

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=4390

HymnToLife

28-10-2007 23:17:38

Greetings ^^

I'm using the rt73 driver with an Asus WL-167g adapter in Gentoo (kernel 2.6.22). The driver works fine (I'm writing this using it), however with a small glitch the MAC address of the AP is not set upon association, and I must set it manually before I'm able to connect

[code10ufz74f]firas@Nobue ~ % sudo iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

eth1 no wireless extensions.

wlan0 RT73 WLAN
Link Quality:0 Signal level:0 Noise level:113
Rx invalid nwid:0 invalid crypt:0 invalid misc:0

firas@Nobue ~ % sudo ifconfig wlan0 up
firas@Nobue ~ % sudo iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

eth1 no wireless extensions.

wlan0 RT73 WLAN ESSID:""
Mode:Managed Frequency=2.412 GHz Bit Rate=54 Mb/s
RTS thr:off Fragment thr:off
Encryption key:off
Link Quality=0/100 Signal level:-121 dBm Noise level:-115 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

firas@Nobue ~ % sudo iwlist wlan0 scan
wlan0 Scan completed :
Cell 01 - Address: MyMACAdress
ESSID:"MyESSID"
Mode:Managed
Channel:1
Encryption key:on
Bit Rates:130 Mb/s

firas@Nobue ~ % sudo iwconfig wlan0 essid MyESSID
firas@Nobue ~ % sudo iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

eth1 no wireless extensions.

wlan0 RT73 WLAN ESSID:"MyESSID"
Mode:Managed Frequency=2.412 GHz Bit Rate=54 Mb/s
RTS thr:off Fragment thr:off
Encryption key:off
Link Quality=0/100 Signal level:-121 dBm Noise level:-115 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
[/code10ufz74f]

And if I process with setting the WEP key and running a DHCP client now, it fails, I also noticed that it reports a link quality of 0. However, if I do

[code10ufz74f]firas@Nobue ~ % sudo iwconfig wlan0 ap MyMACAddress[/code10ufz74f]

I'm fine, link quality is 100 and I can connect

[code10ufz74f]firas@Nobue ~ % sudo iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

eth1 no wireless extensions.

wlan0 RT73 WLAN ESSID:"MyESSID"
Mode:Managed Frequency=2.412 GHz Access Point: MyMACAddress
Bit Rate=54 Mb/s
RTS thr:off Fragment thr:off
Encryption key:off
Link Quality=100/100 Signal level:-28 dBm Noise level:-79 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

firas@Nobue ~ % sudo iwconfig wlan0 key MyKey
firas@Nobue ~ % sudo dhcpcd wlan0
firas@Nobue ~ % ping www.google.fr
PING www.l.google.com (66.102.9.147) 56(84) bytes of data.
64 bytes from lm-in-f147.google.com (66.102.9.147): icmp_seq=1 ttl=238 time=93.9 ms[/code10ufz74f]

Any ideas about why I have to set the MAC address manually ? I don't think that's normal, is it ?