Suse 10.3, DWL-G122 and a noob

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=4445

davidmr

17-11-2007 10:21:48

Ok, I recently bought a wireless USB dongle from Dlink ( DWL-G122 with Firmware revision C1) and i am having trouble with it.

I am using OpenSuse 10.3 and am new to linux. I have seen articles all over the net for various solutions to my problem but none seemed to work out.

I downloaded the offical RT73 drivers from RAlinktech.com and the modified RT73 drivers from this site and compiled them but i have 2 issues....

1) i cant get it to start automatically when i turn on my linux box
2) I cant put the card in monitor mode (all i have the option to is Managed/Ad-Hoc and master)

Now, i go to the point where it was installed by fluke and by following various guides on the net but i cant seem to find an actual official guide, there are instructions on serialmonkey (HOWTO section) for various linux flavours but not for SUSE.

Im really looking forward to kissing goodbye to my dependancy on windows but need some help to get on that road...

any help is appreciated guys.

btw do me a favour and dont just post links randomly to other topics that look similar, ive tried about 5 different guides and they seem to all contribute but neither helped fully...
(if you need anymore info id be more than happy to give it, just ask)

Spy84464

18-11-2007 15:58:58

Hello,

1) i cant get it to start automatically when i turn on my linux box[/quote3hxvccdr]
Well, there is certainly a way to do so with Suse, but being a Debian user, I have no idea how to. You may have more chance on a Suse forum.

2) I cant put the card in monitor mode (all i have the option to is Managed/Ad-Hoc and master)
[/quote3hxvccdr]
You'll likely using Ralink's driver then, because all our drivers support monitor mode. master mode is surprising, have you actually tried it?

Regards,
Romain

davidmr

18-11-2007 16:11:27

i havent tried it, i will do so when i get the system up and running again, i make so many changes that i need to keep track of what i am doing )

hennichodernich

19-11-2007 07:43:57

Hello,

1) i cant get it to start automatically when i turn on my linux box[/quoteuzt5jzw4]
Well, there is certainly a way to do so with Suse, but being a Debian user, I have no idea how to. You may have more chance on a Suse forum.
[/quoteuzt5jzw4]
Or just search this forum. Patches for openSUSE's ifup-wireless script have been posted here in the past.

regards
Henning