Debian Lenny also freezes with rt73

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=4549

daniel_matthes

10-01-2008 12:58:08

I think I have a similar problem like described in "RT73 lockup in gutsy".

Since Monday I have a wireless-router which supports WPA and WPA2. So I deside to test the actually driver (rt73-cvs-2008011003) for my D-LINK-USB-Stick on my embedded system (kernel 2.6.21) with these encryption methods. I have tested also the driver on my debian lenny system (kernel 2.6.22-3), running unter vm-ware. On the embedded system the driver works with WEP, WPA and WPA2 without problems except for the described MAC-Problem (topic rt73 on ARM without hotplug or udev) Debian Lenny freezes when I bring up the device (ifup wlan0). If the USB-stick is plugged during start-up, the system also freezes. The system freezes by using WEP,WPA and WPA2. It doesn't matter which security option I chose.

Spy84464

11-01-2008 21:44:41

Hello,
More than the "interfaces" file, a debug trace would be very useful to see what is happening. See the TESTING file, coming with the driver, for details.

Regards,
Romain

daniel_matthes

29-01-2008 15:45:23

Hello,

[quote1iv0dsph]
Hello,
More than the "interfaces" file, a debug trace would be very useful to see what is happening. See the TESTING file, coming with the driver, for details.
[/quote1iv0dsph]

The system still freeze when I plug in the wlan adapter by using the actually driver(rt73-cvs-2008012904). Not ever, but often.

I have attached /var/log/debug /var/log/messages and /var/log/kern.log after a system freeze. The system freezes at 161345. I restartet the system at 161450

Regards Daniel