wlan0 not recognized by ifconifg

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=4593

ben3000

02-02-2008 03:22:09

I followed the steps in TESTING and there were no errors in the debug

Feb 1 205305 ben4 kernel rtusb init ====>
Feb 1 205305 ben4 kernel usbcore registered new interface driver rt7


When I do ifconfig wlan0 up I get

wlan0 ERROR while getting interface flags No such device

uname -a

Linux ben4 2.6.22-3-686 #1 SMP Mon Nov 12 083257 UTC 2007 i686 GNU/Linux

(Debian sid)

Hardware

Belkin f5d7050 version 5XXX

modinfo rt73.kofilename rt73.ko
license GPL
description Ralink RT73 802.11abg WLAN Driver 1.0.3.6 CVS 2008020120
author http//rt2x00.serialmonkey.com
alias usbv1740p7100d*dc*dsc*dp*ic*isc*ip*
alias usbv2019pAB50d*dc*dsc*dp*ic*isc*ip*
alias usbv2019pAB01d*dc*dsc*dp*ic*isc*ip*
alias usbv0769p31F3d*dc*dsc*dp*ic*isc*ip*
alias usbv0DF6p90ACd*dc*dsc*dp*ic*isc*ip*
alias usbv0DF6p9712d*dc*dsc*dp*ic*isc*ip*
alias usbv18E8p6238d*dc*dsc*dp*ic*isc*ip*
alias usbv18E8p6229d*dc*dsc*dp*ic*isc*ip*
alias usbv18E8p6196d*dc*dsc*dp*ic*isc*ip*
alias usbv148Fp2671d*dc*dsc*dp*ic*isc*ip*
alias usbv148Fp2573d*dc*dsc*dp*ic*isc*ip*
alias usbv0DB0pA874d*dc*dsc*dp*ic*isc*ip*
alias usbv0DB0pA861d*dc*dsc*dp*ic*isc*ip*
alias usbv0DB0p6874d*dc*dsc*dp*ic*isc*ip*
alias usbv0DB0p6877d*dc*dsc*dp*ic*isc*ip*
alias usbv13B1p0023d*dc*dsc*dp*ic*isc*ip*
alias usbv13B1p0020d*dc*dsc*dp*ic*isc*ip*
alias usbv06F8pE020d*dc*dsc*dp*ic*isc*ip*
alias usbv06F8pE010d*dc*dsc*dp*ic*isc*ip*
alias usbv1472p0009d*dc*dsc*dp*ic*isc*ip*
alias usbv1044p800Ad*dc*dsc*dp*ic*isc*ip*
alias usbv1044p8008d*dc*dsc*dp*ic*isc*ip*
alias usbv15A9p0004d*dc*dsc*dp*ic*isc*ip*
alias usbv07D1p3C04d*dc*dsc*dp*ic*isc*ip*
alias usbv07D1p3C03d*dc*dsc*dp*ic*isc*ip*
alias usbv14B2p3C22d*dc*dsc*dp*ic*isc*ip*
alias usbv1371p9032d*dc*dsc*dp*ic*isc*ip*
alias usbv1371p9022d*dc*dsc*dp*ic*isc*ip*
alias usbv1631pC019d*dc*dsc*dp*ic*isc*ip*
alias usbv050Dp905Cd*dc*dsc*dp*ic*isc*ip*
alias usbv050Dp905Bd*dc*dsc*dp*ic*isc*ip*
alias usbv050Dp705Ad*dc*dsc*dp*ic*isc*ip*
alias usbv050Dp7050d*dc*dsc*dp*ic*isc*ip*
alias usbv0411p00F4d*dc*dsc*dp*ic*isc*ip*
alias usbv0B05p1724d*dc*dsc*dp*ic*isc*ip*
alias usbv0B05p1723d*dc*dsc*dp*ic*isc*ip*
alias usbv1690p0722d*dc*dsc*dp*ic*isc*ip*
alias usbv07B8pB21Dd*dc*dsc*dp*ic*isc*ip*
depends usbcore,firmware_class
vermagic 2.6.22-3-686 SMP mod_unload 686
parm debugDebug mask n selects filter, 0 for none (int)
parm ifnameNetwork device name (default wlan%d) (charp)
parm firmNamePermit to load a different firmware (default rt73.bin) (charp)





Thanks a bunch,

IvD

02-02-2008 11:54:49

The driver doesn't recognize your card. Are you sure you have a rt73usb cad, what does lsusb report?

ben3000

02-02-2008 22:47:39

lsusb

Bus 005 Device 003 ID 050d705e Belkin Components
Bus 005 Device 001 ID 00000000
Bus 004 Device 001 ID 00000000
Bus 003 Device 001 ID 00000000
Bus 002 Device 001 ID 00000000
Bus 001 Device 001 ID 00000000

IvD

02-02-2008 23:00:17

Are you sure you have a rt73usb card, Belkin is notoreous for changing chipsets often, and this USB id is unknown....
So why do you think this is a rt73 device? What is the name of the windows driver? Is there a name on the chipset in the device?

ben3000

03-02-2008 02:57:52

my bad, it turns out the 5000 series might not use Ralink at all. Thanks though.


theard about rt73
http//www.linuxquestions.org/hcl/showp ... 20&cat=128

windows drivers blkwgu.inf and blkwgu.sys.