rt73 on ARM(uClinux-2.4.17)

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=4833

answer_zy

06-06-2008 09:20:58

Hi,
i'm trying to setup an ARM(uClinux-2.4.17) device to use rt73

I download the rt73 driver from
[urlmonlzmyx]http://www.ralinktech.com.tw/data/drivers/2008_0506_RT73_Linux_STA_Drv1.1.0.1.tar.bz2[/urlmonlzmyx]
and when I cross-compile it , i get this
[codemonlzmyx]rtmp_main.c: In function `rt73_get_wireless_stats':
rtmp_main.c:355: warning: comparison is always false due to limited range of data type
rtmp_main.c: In function `usb_rtusb_probe':
rtmp_main.c:969: structure has no member named `wireless_handlers'
rtmp_main.c:976: structure has no member named `weight'
make[3]: *** [rtmp_main.o] ?? 1[/codemonlzmyx]

So I delete these two line
and compile it again, i get the following error
[codemonlzmyx]assoc.c:38: net/iw_handler.h: ?????????
make[3]: *** [assoc.o] ?? 1[/codemonlzmyx]
then I copy an iw_handler.h from linux-2.4.20 to my uClinux-2.4.17/include/net/ and this time I compile it success.

I copy rt73.o rt73.bin rt73sta.dat to my romfs and try to make it works.

1.
[codemonlzmyx]
/> insmod lib/rt73.o
Using lib/rt73.o
-RT73-<7>usb_rtusb_init-->
usb.c: registered new driver rt73
-RT73-<7>usb_rtusb_probe-->
idVendor = 0x18e8, idProduct = 0x6238
-RT73-<7>usb device name rausb0
-RT73-<7>BulkOutMaxPacketSize 64
-RT73-<7>usb_rtusb_init_device-->
-RT73-<7>--> PortCfgInit
-RT73-<7><-- PortCfgInit
-RT73-<7>--> RTMPInitAdapterBlock
-RT73-<7><-- RTMPInitAdapterBlock
-RT73-<7>--> NICInitTransmit
-RT73-<7>--> NICInitRecv
-RT73-<7><-- NICInitRecv
-RT73-<7>Init: MAC_CSR0=0x0002573a, Status=0x00000004
-RT73-<7>--> NICLoadFirmware
ERROR!!! <7>NICLoadFirmware: Ver=1.7, local Ver=2.2, used FirmwareImage talbe instead
-RT73-<7>NICLoadFirmware failed, used local Firmware(v 2.2) instead
-RT73-<7><-- NICLoadFirmware (src=/etc/Wireless/RT73STA/rt73.bin)
-RT73-<7>--> NICInitializeAsic
-RT73-<7>BBP version = 22
-RT73-<7><-- NICInitializeAsic
-RT73-<7>RTMPReadParametersFromFile::(CountryRegion=0)
-RT73-<7>RTMPReadParametersFromFile::(CountryRegionABand=7)
-RT73-<7>RTMPReadParametersFromFile::(SSID=tenda)
-RT73-<7>RTMPReadParametersFromFile::(NetworkType=1)
-RT73-<7>RTMPSetPhyMode(=4) 255
-RT73-<7>country code=0/7, RFIC=1, PHY mode=4, support 11 channels
<7>channel #1
<7>channel #2
<7>channel #3
<7>channel #4
<7>channel #5
<7>channel #6
<7>channel #7
<7>channel #8
<7>channel #9
<7>channel #10
<7>channel #11
-RT73-<7> MlmeUpdateTxRates (MaxDesire=54, MaxSupport=54, MaxTxRate=54, Rate Switching =1)
-RT73-<7> MlmeUpdateTxRates (TxRate=54, RtsRate=2, BasicRateBitmap=0x015f)
-RT73-<7>AsicSetSlotTime(=9 us)
-RT73-<7>RTMPReadParametersFromFile::(WirelessMode=4)
-RT73-<7> RTMPSetDesiredRates (6c,60,48,30,16,0b,04,02)
-RT73-<7> MlmeUpdateTxRates (MaxDesire=54, MaxSupport=54, MaxTxRate=54, Rate Switching =1)
-RT73-<7> MlmeUpdateTxRates (TxRate=54, RtsRate=2, BasicRateBitmap=0x015f)
-RT73-<7>RTMPReadParametersFromFile::(TxRate=0)
-RT73-<7>RTMPReadParametersFromFile::(BGProtection=0)
-RT73-<7>MlmeSetTxPreamble (= LONG PREAMBLE)
-RT73-<7>RTMPReadParametersFromFile::(TxPreamble=0)
-RT73-<7>RTMPReadParametersFromFile::(RTSThreshold=2347)
-RT73-<7>RTMPReadParametersFromFile::(FragThreshold=2346)
-RT73-<7>RTMPReadParametersFromFile::(TxBurst=0)
-RT73-<7>RTMPReadParametersFromFile::(TurboRate=0)
-RT73-<7>RTMPReadParametersFromFile::(IEEE80211H=0)
-RT73-<7>MlmeSetPsmBit = 0
-RT73-<7>RTMPReadParametersFromFile::(PSMode=0)
-RT73-<7>RTMPReadParametersFromFile::(AdhocOfdm=0)
-RT73-<7>RTMPReadParametersFromFile::(FastRoaming=0)
-RT73-<7>RTMPReadParametersFromFile::(RoamThreshold=-70)
-RT73-<7>RTMPReadParametersFromFile::(AuthMode=0)
-RT73-<7>RTMPReadParametersFromFile::(EncrypType=1)
-RT73-<7>RTMPReadParametersFromFile::(DefaultKeyID, KeyType, KeyStr !!!!!!!!!)
-RT73-<7> DefaultKeyID(0~3)=0
-RT73-<7> Key1Str=0123456789 and type=Hex
-RT73-<7> Key2Str is Invalid key length!
-RT73-<7> Key3Str is Invalid key length!
-RT73-<7> Key4Str is Invalid key length!
-RT73-<7>--> NICReadEEPROMParameters
<7>Local MAC = 00:0d:f0:4b:bb:e0
-RT73-<7>E2PROM: Version = 1, FAE release #4
-RT73-<7>E2PROM: G Tssi[-4 .. +4] = 255 255 255 255 - 255 -255 255 255 255, step=255, tuning=0
-RT73-<7>E2PROM: A Tssi[-4 .. +4] = 255 255 255 255 - 255 -255 255 255 255, step=255, tuning=0
-RT73-<7>E2PROM: RF freq offset=0x11
-RT73-<7><-- NICReadEEPROMParameters
-RT73-<7>--> NICInitAsicFromEEPROM
-RT73-<7>pAd->RfIcType = 2
-RT73-<7>Use Hw Radio Control Pin=1; if used Pin=1;
-RT73-<7>RFIC=2, LED mode=1
-RT73-<7><-- NICInitAsicFromEEPROM
<7>Local MAC = 00:0d:f0:4b:bb:e0
-RT73-<7>RTMPSetPhyMode(=4) 255
-RT73-<7>country code=0/7, RFIC=2, PHY mode=4, support 11 channels
<7>channel #1
<7>channel #2
<7>channel #3
<7>channel #4
<7>channel #5
<7>channel #6
<7>channel #7
<7>channel #8
<7>channel #9
<7>channel #10
<7>channel #11
-RT73-<7> MlmeUpdateTxRates (MaxDesire=54, MaxSupport=54, MaxTxRate=54, Rate Switching =1)
-RT73-<7> MlmeUpdateTxRates (TxRate=54, RtsRate=2, BasicRateBitmap=0x015f)
-RT73-<7> RTMPSetDesiredRates (6c,60,48,30,16,0b,04,02)
-RT73-<7> MlmeUpdateTxRates (MaxDesire=54, MaxSupport=54, MaxTxRate=54, Rate Switching =1)
-RT73-<7> MlmeUpdateTxRates (TxRate=54, RtsRate=2, BasicRateBitmap=0x015f)
-RT73-<7>--> MLME Initialize
-RT73-<7><-- MLME Initialize
-RT73-<7>usb_rtusb_init_device<--
-RT73-<7>usb_rtusb_probe<--
[/codemonlzmyx]

2.
[codemonlzmyx]/> ifconfig rausb0 inet 192.168.0.19 up
-RT73-<7>usb_rtusb_open-->
-RT73-<7>--> PortCfgInit
-RT73-<7><-- PortCfgInit
-RT73-<7>Init: MAC_CSR0=0x0002573a, Status=0x00000004
-RT73-<7>RTMPReadParametersFromFile::(CountryRegion=0)
-RT73-<7>RTMPReadParametersFromFile::(CountryRegionABand=7)
-RT73-<7>RTMPReadParametersFromFile::(SSID=tenda)
-RT73-<7>RTMPReadParametersFromFile::(NetworkType=1)
-RT73-<7>RTMPSetPhyMode(=4) 255
-RT73-<7>country code=0/7, RFIC=1, PHY mode=4, support 11 channels
<7>channel #1
<7>channel #2
<7>channel #3
<7>channel #4
<7>channel #5
<7>channel #6
<7>channel #7
<7>channel #8
<7>channel #9
<7>channel #10
<7>channel #11
-RT73-<7> MlmeUpdateTxRates (MaxDesire=54, MaxSupport=54, MaxTxRate=54, Rate Switching =1)
-RT73-<7> MlmeUpdateTxRates (TxRate=54, RtsRate=2, BasicRateBitmap=0x015f)
-RT73-<7>RTMPReadParametersFromFile::(WirelessMode=4)
-RT73-<7> RTMPSetDesiredRates (6c,60,48,30,16,0b,04,02)
-RT73-<7> MlmeUpdateTxRates (MaxDesire=54, MaxSupport=54, MaxTxRate=54, Rate Switching =1)
-RT73-<7> MlmeUpdateTxRates (TxRate=54, RtsRate=2, BasicRateBitmap=0x015f)
-RT73-<7>RTMPReadParametersFromFile::(TxRate=0)
-RT73-<7>RTMPReadParametersFromFile::(BGProtection=0)
-RT73-<7>MlmeSetTxPreamble (= LONG PREAMBLE)
-RT73-<7>RTMPReadParametersFromFile::(TxPreamble=0)
-RT73-<7>RTMPReadParametersFromFile::(RTSThreshold=2347)
-RT73-<7>RTMPReadParametersFromFile::(FragThreshold=2346)
-RT73-<7>RTMPReadParametersFromFile::(TxBurst=0)
-RT73-<7>RTMPReadParametersFromFile::(TurboRate=0)
-RT73-<7>RTMPReadParametersFromFile::(IEEE80211H=0)
-RT73-<7>MlmeSetPsmBit = 0
-RT73-<7>RTMPReadParametersFromFile::(PSMode=0)
-RT73-<7>RTMPReadParametersFromFile::(AdhocOfdm=0)
-RT73-<7>RTMPReadParametersFromFile::(FastRoaming=0)
-RT73-<7>RTMPReadParametersFromFile::(RoamThreshold=-70)
-RT73-<7>RTMPReadParametersFromFile::(AuthMode=0)
-RT73-<7>RTMPReadParametersFromFile::(EncrypType=1)
-RT73-<7>RTMPReadParametersFromFile::(DefaultKeyID, KeyType, KeyStr !!!!!!!!!)
-RT73-<7> DefaultKeyID(0~3)=0
-RT73-<7> Key1Str=0123456789 and type=Hex
-RT73-<7> Key2Str is Invalid key length!
-RT73-<7> Key3Str is Invalid key length!
-RT73-<7> Key4Str is Invalid key length!
-RT73-<7>--> NICReadEEPROMParameters
<7>Local MAC = 00:0d:f0:4b:bb:e0
-RT73-<7>E2PROM: Version = 1, FAE release #4
-RT73-<7>E2PROM: G Tssi[-4 .. +4] = 255 255 255 255 - 255 -255 255 255 255, step=255, tuning=0
-RT73-<7>E2PROM: A Tssi[-4 .. +4] = 255 255 255 255 - 255 -255 255 255 255, step=255, tuning=0
-RT73-<7>E2PROM: RF freq offset=0x11
-RT73-<7><-- NICReadEEPROMParameters
-RT73-<7>--> NICInitAsicFromEEPROM
-RT73-<7>pAd->RfIcType = 2
-RT73-<7>Use Hw Radio Control Pin=1; if used Pin=1;
-RT73-<7>RFIC=2, LED mode=1
-RT73-<7><-- NICInitAsicFromEEPROM
<7>Local MAC = 00:0d:f0:4b:bb:e0
-RT73-<7>RTMPSetPhyMode(=4) 4
-RT73-<7> RTMPSetDesiredRates (6c,60,48,30,16,0b,04,02)
-RT73-<7> MlmeUpdateTxRates (MaxDesire=54, MaxSupport=54, MaxTxRate=54, Rate Switching =1)
-RT73-<7> MlmeUpdateTxRates (TxRate=54, RtsRate=2, BasicRateBitmap=0x015f)
=> usb_rtusb_open
-RT73-<7>AsicSwitchChannel(RF=2) to #1, TXPwr=16%, R1=0x94002c0c, R2=0x94000786, R3=0x9406a055, R4=0x940d1a0b
-RT73-<7>usb_rtusb_open<--
pid 30: failed 256
/> -RT73-<7>RSSI=-121, CCA=1, --R17= 0x1c
-RT73-<7>CNTL - No matching BSS, start a new ACTIVE scan SSID[tenda]
-RT73-<7>SCANNING, suspend MSDU transmission ...
-RT73-<7>SYNC - MlmeScanReqAction
-RT73-<7>--->Disable TSF synchronization
-RT73-<7>AsicSwitchChannel(RF=2) to #1, TXPwr=16%, R1=0x94002c0c, R2=0x94000786, R3=0x9406a055, R4=0x940d1a0b
-RT73-<7><---MlmeRate 1 Channel 1
-RT73-<7>AsicSwitchChannel(RF=2) to #2, TXPwr=16%, R1=0x94002c0c, R2=0x94000786, R3=0x9406a055, R4=0x940d1a1f
-RT73-<7><---MlmeRate 1 Channel 2
-RT73-<7>AsicSwitchChannel(RF=2) to #3, TXPwr=16%, R1=0x94002c0c, R2=0x9400078a, R3=0x9406a055, R4=0x940d1a0b
-RT73-<7><---MlmeRate 1 Channel 3
-RT73-<7>AsicSwitchChannel(RF=2) to #4, TXPwr=16%, R1=0x94002c0c, R2=0x9400078a, R3=0x9406a055, R4=0x940d1a1f
-RT73-<7><---MlmeRate 1 Channel 4
-RT73-<7>AsicSwitchChannel(RF=2) to #5, TXPwr=16%, R1=0x94002c0c, R2=0x9400078e, R3=0x9406a055, R4=0x940d1a0b
-RT73-<7><---MlmeRate 1 Channel 5
-RT73-<7>AsicSwitchChannel(RF=2) to #6, TXPwr=16%, R1=0x94002c0c, R2=0x9400078e, R3=0x9406a055, R4=0x940d1a1f
-RT73-<7><---MlmeRate 1 Channel 6
-RT73-<7>AsicSwitchChannel(RF=2) to #7, TXPwr=16%, R1=0x94002c0c, R2=0x94000792, R3=0x9406a055, R4=0x940d1a0b
-RT73-<7><---MlmeRate 1 Channel 7
-RT73-<7>AsicSwitchChannel(RF=2) to #8, TXPwr=16%, R1=0x94002c0c, R2=0x94000792, R3=0x9406a055, R4=0x940d1a1f
-RT73-<7><---MlmeRate 1 Channel 8
-RT73-<7>AsicSwitchChannel(RF=2) to #9, TXPwr=16%, R1=0x94002c0c, R2=0x94000796, R3=0x9406a055, R4=0x940d1a0b
-RT73-<7><---MlmeRate 1 Channel 9
-RT73-<7>AsicSwitchChannel(RF=2) to #10, TXPwr=16%, R1=0x94002c0c, R2=0x94000796, R3=0x9406a055, R4=0x940d1a1f
-RT73-<7><---MlmeRate 1 Channel 10
-RT73-<7>AsicSwitchChannel(RF=2) to #11, TXPwr=16%, R1=0x94002c0c, R2=0x9400079a, R3=0x9406a055, R4=0x940d1a0b
-RT73-<7><---MlmeRate 1 Channel 11
-RT73-<7>SYNC - End of SCAN, restore to channel 1
-RT73-<7>AsicSwitchChannel(RF=2) to #1, TXPwr=16%, R1=0x94002c0c, R2=0x94000786, R3=0x9406a055, R4=0x940d1a0b
-RT73-<7>SCAN done, resume MSDU transmission ...
-RT73-<7>Driver auto reconnect to last OID_802_11_SSID setting - tenda
-RT73-<7>CNTL - 1 BSS match the desire SSID - tenda
-RT73-<7>CNTL - iterate BSS 0 of 1
-RT73-<7>SYNC - MlmeJoinReqAction(BSS #0)
-RT73-<7>MlmeJoinReqAction - PortCfg.Ssid[5]=tenda... MlmeAux.Ssid[5]=tenda
-RT73-<7>Beacon SSID(NULL)=0 SSID(empty)=0 Len<0=0 station SsidLen(==0)=1 SYNC - SSID[5]=tenda
-RT73-<7>AsicSwitchChannel(RF=2) to #6, TXPwr=16%, R1=0x94002c0c, R2=0x9400078e, R3=0x9406a055, R4=0x940d1a1f
-RT73-<7>SYNC - Switch to channel 6, SSID tenda
-RT73-<7>SYNC - Wait BEACON from 20:03:7f:1f:0f:1f ...
-RT73-<7>SYNC - receive desired BEACON at JoinWaitBeacon... Channel = 6
-RT73-<7>SYNC - after JOIN, SupRateLen=4, ExtRateLen=0
-RT73-<7>AUTH - Send AUTH request seq#1 (Alg=0) 6...
-RT73-<7><---MlmeRate 1 Channel 6
-RT73-<7>AUTH - Receive AUTH_RSP seq#2 to me (Alg=0, Status=0)
-RT73-<7>CNTL - AUTH OK
-RT73-<7>ASSOC - Send ASSOC request...
-RT73-<7><---MlmeRate 1 Channel 6
-RT73-<7>ASSOC - receive ASSOC_RSP to me (status=0)
-RT73-<7>!!! LINK UP !!! (Infra=1, AID=1, ssid=tenda)
-RT73-<7>>>>AsicSetBssid<<<
-RT73-<7>AsicSetEdcaParm
-RT73-<7> MlmeUpdateTxRates (Rssi=-64, init TX rate = 11 Mbps)
-RT73-<7> MlmeUpdateTxRates (MaxDesire=54, MaxSupport=11, MaxTxRate=11, Rate Switching =1)
-RT73-<7> MlmeUpdateTxRates (TxRate=11, RtsRate=2, BasicRateBitmap=0x000f)
-RT73-<7>NDIS_STATUS_MEDIA_DISCONNECT Event AA!
-RT73-<7>--->AsicEnableBssSync(INFRA mode)
-RT73-<7>NDIS_STATUS_MEDIA_CONNECT Event B!
-RT73-<7>CNTL - Association successful on BSS #0
-RT73-<7>AsicSetSlotTime(=20 us)
-RT73-<7>SYNC - New AP added to SsidBssTab[1], RSSI=192, MAC=22:03:7f:1f:0f:1f
-RT73-<7>mid RSSI=-64, CCA=7, fixed R17 at 0x2c
-RT73-<7>mid RSSI=-64, CCA=0, fixed R17 at 0x2c
-RT73-<7>AntDiv - before evaluate Pair1-Ant (0,1), Pair2-Ant (0,0)
-RT73-<7>After Eval,RSSI[0,1,2,3]=<192,192,0,0>,RcvPktNumWhenEvaluate=1
-RT73-<7>After Eval-Pair1 #1,Pair2 #0
-RT73-<7>mid RSSI=-64, CCA=0, fixed R17 at 0x2c
-RT73-<7>mid RSSI=-63, CCA=0, fixed R17 at 0x2c
-RT73-<7>mid RSSI=-64, CCA=0, fixed R17 at 0x2c
-RT73-<7>mid RSSI=-63, CCA=0, fixed R17 at 0x2c
-RT73-<7>mid RSSI=-64, CCA=0, fixed R17 at 0x2c
-RT73-<7>mid RSSI=-63, CCA=0, fixed R17 at 0x2c
-RT73-<7>mid RSSI=-63, CCA=0, fixed R17 at 0x2c
-RT73-<7>SYNC - send NULL Frame @11 Mbps...
-RT73-<7>mid RSSI=-63, CCA=0, fixed R17 at 0x2c
-RT73-<7>mid RSSI=-63, CCA=0, fixed R17 at 0x2c
-RT73-<7>mid RSSI=-64, CCA=0, fixed R17 at 0x2c
-RT73-<7>mid RSSI=-63, CCA=0, fixed R17 at 0x2c
-RT73-<7>mid RSSI=-63, CCA=0, fixed R17 at 0x2c
-RT73-<7>mid RSSI=-63, CCA=0, fixed R17 at 0x2c
-RT73-<7>mid RSSI=-64, CCA=0, fixed R17 at 0x2c
-RT73-<7>mid RSSI=-63, CCA=0, fixed R17 at 0x2c
-RT73-<7>mid RSSI=-64, CCA=0, fixed R17 at 0x2c
-RT73-<7>mid RSSI=-63, CCA=0, fixed R17 at 0x2c
-RT73-<7>SYNC - send NULL Frame @11 Mbps...
-RT73-<7>mid RSSI=-64, CCA=0, fixed R17 at 0x2c
-RT73-<7>mid RSSI=-64, CCA=0, fixed R17 at 0x2c
-RT73-<7>mid RSSI=-64, CCA=2, fixed R17 at 0x2c
-RT73-<7>mid RSSI=-64, CCA=0, fixed R17 at 0x2c
-RT73-<7>mid RSSI=-65, CCA=0, fixed R17 at 0x2c
-RT73-<7>mid RSSI=-65, CCA=0, fixed R17 at 0x2c
-RT73-<7>mid RSSI=-66, CCA=0, fixed R17 at 0x2c
-RT73-<7>mid RSSI=-66, CCA=0, fixed R17 at 0x2c
[/codemonlzmyx]
this message seems will never stop.

3.
[codemonlzmyx]/> ifconfig
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

rausb0 Link encap:Ethernet HWaddr 00:0D:F0:4B:BB:E0
inet addr:192.168.0.19 Bcast:192.168.0.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:3411 errors:0 dropped:0 overruns:0 frame:0
TX packets:23 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:256941 (250.9 KiB) TX bytes:1440 (1.4 KiB)
[/codemonlzmyx]

4.
[codemonlzmyx]/> iwconfig rausb0 essid linksys
Error for wireless request "Set ESSID" (8B1A) :
SET failed on device rausb0 ; Invalid argument.
pid 32: failed 64256
[/codemonlzmyx]


This is my rt73sta.dat
[codemonlzmyx]
[Default]
CountryRegion=0
CountryRegionABand=7
WirelessMode=4
SSID=linksys
NetworkType=Infra
Channel=0
AuthMode=OPEN
EncrypType=NONE
DefaultKeyID=1
Key1Type=0
Key1Str=0123456789
Key2Type=0
Key2Str=
Key3Type=0
Key3Str=
Key4Type=0
Key4Str=
WPAPSK=abcdefghijklmnopqrstuvwxyz
TxBurst=0
PktAggregate=0
TurboRate=0
WmmCapable=0
AckPolicy=0;0;0;0
BGProtection=0
IEEE80211H=0
TxRate=0
RTSThreshold=2347
FragThreshold=2346
PSMode=CAM
TxPreamble=0
AdhocOfdm=0
FastRoaming=0
RoamThreshold=70
NativeWpa=1
[/codemonlzmyx]

Anybody can help me

Thanks and sorry for my poor english...

Starcrasher

06-06-2008 11:17:08

You are using the legacy driver from Ralink not the rt2x00 one.
So, if you want help about this driver, you'd better ask where you have download it.
Do you really think M$ is anwering linux questions ? lol
Anyway, there's from time to time people like you searching help for this driver. Maybe are you lucky and will find an answer using the magical search button on top right of the page. wink

bupt

23-12-2008 07:34:46

hi,answer_zy , i'm trying to setup an PowerPC(linux 2.6.13?device to use rt73 now, and I came across the same problm with you when using the driver RT73_Linux_STA_Drv1.0.4.0.
did you solve this problem ? Thanks

IvD

23-12-2008 19:01:07

hi,answer_zy , i'm trying to setup an PowerPC(linux 2.6.13?device to use rt73 now, and I came across the same problm with you when using the driver RT73_Linux_STA_Drv1.0.4.0.
did you solve this problem ? Thanks[/quote34jgwsf8]

Then for you the same notice
RT73_Linux_STA_Drv1.0.4.0 does not originate from this project, so there is no support here for it. Either download the drivers from our project or ask support on the site where you downloaded the drivers.