Rutilt scan doesn't recognize WPA

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=5071

vkon15

05-11-2008 08:59:42

Greetings,
I am having problems connecting to my router with my Linksys WUSB54GC. I am using Slackware 12.1 with the 2.6.24.5-smp kernel. I have compiled and installed the rt73 driver myself, however after following the guide for manual configuration and trying to execute 'iwpriv wlan0 set AuthMode=WPAPSK' I get an error 'wlan0 no private ioctls.'
To bypass this I am trying to use rutilt to connect to my network, the problem I encounter is when I perform the scan - my network comes up however its incorrectly being recognized as WEP, and if i try to connect to it or add to a profile there are no options to set it as WPA.

[img195fb7xf]http://img527.imageshack.us/img527/9007/rutiltci3.jpg[/img195fb7xf]

The network is setup correctly and comes up fine with iwlist wlan0 scan.

[img195fb7xf]http://img120.imageshack.us/img120/6531/iwlistkk8.jpg[/img195fb7xf]

Would anyone have any suggestions regarding a way of solving this issue, or perhaps be able to send me the contents of their rutilt profile with wpa settings in it, I would like to try and modify it to my own settings and connect to it with rutilt through console.

Another question I have, is regarding the installation of wmaster0 interface, which I think came with the driver, is there a way to remove it?

vkon15

05-11-2008 10:54:48

I managed to solve the issue while browsing these forums, and googling. Will share my experiences with others who might have this problem.
I am a Linux newbie so if someone wants to correct my actions please do so.
Apparently I had rt73usb preinstalled with my distribution, and although I compiled the new rt73 cvs myself, wlan0 was associated with the rt73usb.
I ran 'lsmod | less' to see which modules I had running in my system, and noticed rt73usb and rt2x00usb in there. I ran edited /etc/modprobe.d/blacklist and added 'blacklist rt73usb' and 'blacklist 'rt2x00usb' to it. I then brought both of them down with the 'modprobe -r rt73usb' command.
I then tried to follow the instructions which came with the rt73 cvs README file. However I could not bring up the wlan0 interface up, until I manually copied rt73.bin which I compiled into /lib/firmware, and ran the 'modprobe rt73 ifname=wlan0 firmName=rt73.bin' command.
From here on I was able to follow the guide exactly without any problems and connect to my router. This solved my "no priv ioctls" error from iwpriv as well as having wmaster0 interface.