WPA

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=5124

usbdongle

13-12-2008 19:42:09

Hi all,

I've been using rt73usb since the end of '07. Unfortunately the driver for my modem doesn't work on kernels newer than 2.6.19, and as such I'm stuck with the legacy driver and so have to use Ad-Hoc rather than master mode (
I recently updated to the latest rt73 cvs (which fixed a few things compared to the old '06 driver I'd been using). System load is now 0, rather than 2! Thanks to whoever made that happen.

Now that I have almost no system load I thought it might be an idea to switch from WEP to WPA/WPA. Reading the iwpriv readme and some googling suggested that this should do it

[code2bsqidsc]ifconfig wlan0 up
iwpriv wlan0 set AuthMode=WPAPSK
iwpriv wlan0 set EncrypType=TKIP
iwpriv wlan0 set WPAPSK="YOUR_WPA_PSK_KEY"
iwpriv wlan0 set SSID="YOUR_SSID"
iwpriv wlan0 set NetworkType=Infra[/code2bsqidsc]

Using this (but changing NetworkType to Ad-Hoc) had no effect. Doing a network scan from another machine showed that the network still had a WEP key despite iwconfig on the rt73 machine saying the encryption key was off. I also tried the above in combination with

[code2bsqidsc]iwconfig wlan0 mode Ad-Hoc[/code2bsqidsc]

but that didn't work either. I also tried using the rt73sta.dat file, with no effect.

Any suggestions would be appreciated

Thanks

Spy84464

15-12-2008 22:19:07

Hello,
What doesn't work exactly?
There's a special WPA authentication for ad-hoc, it is set with "iwpriv wlan0 set AuthMode=WPANONE". I suggest you set the mode (ad-hoc or managed) before any other setting.

Regards,
Romain