Rutilt and active prfile on start

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=4110

william7

29-07-2007 01:46:47

How make that the rutilt will be started with apply active profile on boot...
Now I have manually apply profile after each reboot, that's boring /
Is any way to add rutilt to start with always active profile...?
I have Rutilt 0.15.
thanks.

Spy84464

30-07-2007 18:03:55

Hello,
Yes, you can have rutilt apply a profile on boot. Launch it (as root) with the following command
"rutilt -dp [i1gfqvl6x]profile_name_here[/i1gfqvl6x]". The 'd' stand for dhcp, remove it if you use static ip.
If it's launched from a startup script, then add the 'e' option. Check the man page or README for all details ;)

Regards,
Romain

yellowzelo

08-08-2007 12:34:58

Hello,

ive got problem with this. It works, when I type command
[code11gmd2q3]rutilt ra0 -dep "myprofile"[/code11gmd2q3]
But if I put this command to rc script, or place it to rc.local file, it doesnt work. Could you advice me?

Thanks

Starcrasher

09-08-2007 08:28:54

When you start RutilT from rc.local. It's not started by the user ("your_username") but by the system user (usually "root"). It can even happens that no user is already defined.
Therefore, RutilT can't found a profile for this user.
Look at the system messages and try to find what says rutilt and eventually identify that user.

The two solutions are to start rutilt as this user and add the missing profile or, copy the rutilt folder and its content from /home/"your_username"/.config to root/.config. If it's not working, you can then try /.config ("no user" case).

From a user point of view, the second solution is simpler and the only one that can handle the "no user" case. But, in other hand, the first solution is safer.

vanepelw

11-01-2008 03:10:55

I'm using Ubuntu Gutsy. I've tried the above suggestions, but cannot get a wireless network connection to start at boot. I had no problem setting rutilt up to connect and show in my system tray when i log in.

I have copied the profile from my home directory to root/.config/rutilt, and have added the following to my rc.local file
[code38j1mbf5]rutilt wlan0 -dep PROFILE_NAME[/code38j1mbf5]
but i get no connection. I've also added the same line as above to a script which i executed at startup, also with no results.

Also, i have not been able to find any rutilt messages in any of my system logs. Anyone successfully set this up in Ubuntu? Help is greatly appreciated!

Spy84464

11-01-2008 21:29:31

Hello,
The easiest way on Ubuntu is probably to edit "/etc/network/interfaces" and add these lines
[code387a1zvy]iface wlan0 inet
post-up rutilt wlan0 -dep PROFILE_NAME[/code387a1zvy].

Regards,
Romain

vanepelw

17-01-2008 02:00:16

That didn't do it unfortunately...when i add that to the interfaces file, not only does it not connect at startup, but i'm not able to connect after logging in either. Is there a way to debug this more effectively? I haven't been able to find any references to rutilt in any logs while i've been going through this process.

here is my /etc/network/interfaces file (without the rutilt reference, obviously)

[code1etgjyan]auto lo
iface lo inet loopback

# RT61

iface wlan0 inet dhcp

wpa-psk MYENCRYPTEDPSK
wpa-driver wext
wpa-key-mgmt WPA-PSK
wpa-proto WPA
wpa-ssid MYSSID

auto wlan0
[/code1etgjyan]

Thanks again for your help!

Spy84464

22-01-2008 13:18:51

That won't work, you need to use the wpa driver "ralink" (not wext), or whatever it's called. Note that that driver is only shipped with recent version of wpa_supplicant.
Alternatively, and that would probably be easier, you can use "iwpriv", as explained in "iwpriv_usage.txt" coming with the driver, to setup the connection.
This command can be invoke through "/etc/network/interfaces" using the "pre-up" stanza.