RutilT compilation on openSUSE 11

Live forum: http://rt2x00.serialmonkey.com/viewtopic.php?t=5043

shaban

16-10-2008 20:18:13

Hello, this is my first post. I have Susi11 nicely running now WLAN with rt61 driver, but KNetworkmanager and KWifimanager insufficient. I would like to use RutilT 0.18 but have still compiling problems

Kernel 2.6.25.16-0.1-pae, sources installed
kernel-headers-2.6.25-8.1

Because I see no other solution I start compiling with --force.
Then I get stuck
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
./configure.sh --force
Kernel sources cannot be found.
Kernel headers found. They do not match your running kernel. <Check forced>
Generating Makefile constants... done
Generating program constants... ./configure.sh line 276 include/StaticSettings.h Datei oder Verzeichnis nicht gefunden
done
Generating desktop launcher... done
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
What is the StaticSettings.h. Is there a path to be changed?

Is there any precompiled version?

Help much appreciated.

Spy84464

17-10-2008 18:05:19

Hello,
There is no path to change. What means the error you get?
Some people made pre-compiled packages, but I don't know if it has been done for OpenSuse11.

Regards,
Romain

shaban

17-10-2008 22:49:18

Thanks for the quick answer.

The error
"Generating program constants... ./configure.sh line 276 include/StaticSettings.h Datei oder Verzeichnis nicht gefunden"
means in German, that in line 276 of the script the file StaticSettings.h could not be found, so the script stops....

Is it oK to start with --force due to the kernel header "mismatch", which is not really an error but usual?

Kind regards

Nikolaus

Spy84464

22-10-2008 17:54:32

The fact that the kernel headers mismatch your running kernel will not be a problem if the version of the wireless extensions has not changed, which is most likely the case.
I do not understand where the error comes from, configure.sh is supposed to generate StaticSettings.h, not read it, do you have write permissions in the directory "include" of the sources tarball?

shaban

23-10-2008 22:37:50

Thanks for the hint. I am one step further. I started the whole session as root, did [b2gtthyq3]not[/b2gtthyq3] try to do the compiling as a user in "sudo" terminals!
I copied the Rutil 0.18 into a new folder on roots desktop and used the --forced option because of the header mismatch.
Compiling and make and make install went through without error! Super!

But when I start now I get an error which has already been discussed in January A window pops up and says
[quote2gtthyq3]Can't get STA config through special ioctl. Operation not supported by the driver.[/quote2gtthyq3]
I use the rt61 driver with WPAPSK at present. Does Rutil interfere with other WiFi software?

Thanks for your patience!

N

shaban

26-10-2008 19:06:32

Hello again,
by further looking around, I found a possible reason for my failure to start RutilT.
I have configured WPAPSK with iwpriv and [b36u51j7w]not[/b36u51j7w] with WPA supplicant, because I do not know how that works.
So I cannot stop and restart the WLAN while the system is up. It is always started at boot.
But I do not understand yet.
??????????

Spy84464

27-10-2008 19:31:41

RutilT is not using wpa_supplicant at all, but private ioctls (exactly like iwpriv) for WPA, that with all legacy drivers that support it. What is the driver you are using? Did you install it yourself?

shaban

29-10-2008 08:50:15

Now I understand! I think I use the original Driver from the Ralink homepage! I went back to the how-to which was successful

http//www-personal.umich.edu/~mejn/rt61.html This worked also on Opensuse 11.

That driver works flawless, but it only starts on startup. I have no possibilitiy to start and stop while the system is up.
The configuration is created manually in the /etc/Wireless/RT61STA/rt61sta.dat.

It is like this
[quote33axyq8c][Default]
CountryRegion=0
CountryRegionABand=7
WirelessMode=0
SSID=Shaban
NetworkType=Managed
Channel=6
AuthMode=WPAPSK
EncrypType=TKIP
DefaultKeyID=1
Key1Type=0
Key1Str=0123456789
Key2Type=0
Key2Str=
Key3Type=0
Key3Str=
Key4Type=0
Key4Str=
WPAPSK=myKey
TxBurst=0
PktAggregate=0
WmmCapable=0
APSDCapable=0
APSDAC=0;0;0;0
BGProtection=0
IEEE80211H=0
TxRate=0
RTSThreshold=2347
FragThreshold=2346
RoamThreshold=75
PSMode=CAM
TxPreamble=0
FastRoaming=0
NativeWpa=1[/quote33axyq8c]

Does that prevent Rutilt from starting? I would really appreciate to use Rutilt even with the Ralink driver. Where does Rutilt store or look for firmware and WPA settings?
Otherwise I would have to decide to make an experiment with the serialmonkey driver again.

Kind regards

Nikolaus

shaban

29-10-2008 09:38:28

D D D
I could not resist and gave it a try!
Downloaded the latest serialmonkey rt61 driver cvs tarball, compiled, installed, rebooted.

Rutilt started without error, scanned wireless networks and I connected to my router! 8)
I send this mail wireless with the new driver!

I am so thankful for your small hints. Maybe I write an opensuse howto for serialmonkey and Rutilt.

Thanks again, fantastic tool!

Nikolaus

shaban

30-10-2008 23:37:49

? Now with RutilT I am able to start and stop the WLAN card in the running system. I use version 0.18. When I try to do that as a normal user, however I am asked for the root password. The funny thing is, RutilT never accepts my root password when I type it as a normal user, whereas everything works fine when I start RutilT from a root console. ?

Normal behaviour, user fault (mine?), bug?

Kind regards

Nikolaus

Starcrasher

31-10-2008 17:21:00

Have look at the INSTALL file.
There is an option for this, --launcher=built-in | disabled |nopasswd | external[/color2a2bul4u]
The default is --lancher=build-in, you could try --launcher=external.

shaban

03-11-2008 21:32:22

D To close the thread, its working like a dream now! D
I just recompiled rutilt with the -nopassword option, now I can use it as a normal user and start and stop the wireless without reboot.

The router is still on WPAPSK but I think that is safe enough for me.

Thanks a lot for patience and help.
In a few days I will travel and try it on my neighbours WLAN where I have a guest account...