rt2x00.serialmonkey.com

Support forum for the rt2x00 project
It is currently Tue Sep 02, 2014 4:11 am

All times are UTC




Post new topic Reply to topic  [ 26 posts ]  Go to page Previous  1, 2
Author Message
PostPosted: Thu Dec 11, 2008 4:56 pm 
Offline
User avatar

Joined: Sat Jan 14, 2006 6:29 pm
Posts: 897
Location: Carlsbad, California
mgessner wrote:
I'm curious about when this will work because I'm trying to create an access point for a product and we're trying to use the Ralink chipset.
Is this a commercial development effort you're working on?

Thanks,

_________________
Yr Hmbl Obt Svt & c
Bryan - In favor of Big Oil. Big fan of General Grievous.


Top
 Profile  
 
PostPosted: Fri Dec 12, 2008 10:42 am 
Offline

Joined: Wed Dec 03, 2008 6:21 pm
Posts: 7
Quote:
As I said, Ralink might have some solution for the USB TX status reporting, but I doubt it is a correct behavior. Secondly I have serious doubts if their AP mode implementation would work with hostapd.


Well, to be honest I don't care about hostapd, I'd use something else if worked so if anyone knows another solution under Linux, don't hesitate to tell me.


Top
 Profile  
 
PostPosted: Sat Dec 27, 2008 10:33 am 
Offline

Joined: Tue Jul 12, 2005 3:36 pm
Posts: 41
OK, exactly the same problem, tested with 1x rt2500pci and 1x rt61pci card.
With rt61pci I have the "unknown vendor specific information element ignored (vendor OUI 00:10:18 len=9)" line, not with rt2500pci one, but other is same.

offtopic:
Also tested some Atheros and Broadcom cards with hostap, so if original poster is interested, I had most success (indoor, same room) with a Broadcom b43 card (minipci) - cca 1.3 MB/s (down to 600-700) while atheros 5212 was at 600-700 (but unreliable, down to 50), and atheros 5413 card did not work - but that was expected, see
https://kerneltrap.org/mailarchive/linu ... 064/thread
All this with: 2.6.28 + compat-wireless 26-12-2008 + hostapd git 26-12-2008 + libnl 1.1 + slackware 12.2

edit: b43 minipci on a minipci to pci adapter. those adapers usualy compensate for the pci 2.1 problem (no 3.3v) so that could be an even better solution than usb.


Top
 Profile  
 
PostPosted: Sun Jan 04, 2009 3:42 pm 
Offline

Joined: Thu Nov 20, 2008 2:47 pm
Posts: 10
Hello,
I am having the same messages (error MGMT (TX callback) fail)
when working with the latest git hostapd and wireless-testing.

Is there anything new about it ? is it going to be fixed (I wish I could know from where to start in order to fix it , really).
Regards,
Mark


Top
 Profile  
 
PostPosted: Thu Jan 22, 2009 3:41 pm 
Offline

Joined: Thu Jan 22, 2009 3:33 pm
Posts: 1
any news about this problem? Still the same?


Top
 Profile  
 
PostPosted: Fri Apr 24, 2009 8:13 pm 
Offline

Joined: Fri Apr 24, 2009 8:10 pm
Posts: 1
Hello,
So any news ? I having the same troubles !


Top
 Profile  
 
PostPosted: Fri Apr 24, 2009 8:26 pm 
Offline
Site Admin

Joined: Sun Jun 05, 2005 1:01 pm
Posts: 5905
Location: Haarlem, The Netherlands
As far as I know there is somebody working on this issue, although I haven't heard from him since he started.

_________________
Regards,
Ivo van Doorn
Project Administrator
http://rt2x00.serialmonkey.com


Top
 Profile  
 
PostPosted: Sat Aug 22, 2009 4:07 am 
Offline
User avatar

Joined: Thu May 28, 2009 5:30 pm
Posts: 8
Location: Brazil
Looks like I still have this MGMT (TX callback) fail issue, and I'm using rt61pci.

On hostapd output, I receive several of these messages (and basically nothing else):

Code:
STA 00:1c:bf:bb:e1:8c sent probe request for broadcast SSID
MGMT (TX callback) fail
mgmt::proberesp cb

I've described everything I had done, step-by-step at my blog:
http://my.opera.com/CrazyTerabyte/blog/ ... nk-rt61pci

I still want to setup my desktop RaLink RT2561/RT61 PCI card as an access point. After I get it working working, I would also like to enable encryption.

_________________
http://denilson.sa.nom.br/


Top
 Profile  
 
PostPosted: Thu Aug 27, 2009 3:09 am 
Offline

Joined: Sun Sep 21, 2008 11:38 am
Posts: 8
Same problem here under wireless-testing (master-2009-08-25):

MGMT (TX callback) fail
mgmt::proberesp cb

I use the wireless-testing.git and the mastermode seems to be
broken since version v2.6.31-rc2
At the moment I use the wireless-testing.git version v2.6.31-rc1
and the mastermode works very well here.
So you could try to use wireless-testing and check out
the tag v2.6.31-rc1


Top
 Profile  
 
PostPosted: Sat Sep 05, 2009 1:17 pm 
Offline
User avatar

Joined: Thu May 28, 2009 5:30 pm
Posts: 8
Location: Brazil
ZX81 wrote:
At the moment I use the wireless-testing.git version v2.6.31-rc1
and the mastermode works very well here.
So you could try to use wireless-testing and check out
the tag v2.6.31-rc1

I've just tried the tag "v2.6.31-rc1" from this repo:
git://git.kernel.org/pub/scm/linux/kern ... rt2x00.git

The hostapd messages changed to these:
Code:
MGMT (TX callback) ACK
mgmt::proberesp cb

But still no luck in my laptop connecting to the wi-fi.

_________________
http://denilson.sa.nom.br/


Top
 Profile  
 
PostPosted: Fri Oct 23, 2009 4:51 pm 
Offline
User avatar

Joined: Thu May 28, 2009 5:30 pm
Posts: 8
Location: Brazil
2 months after my previous attempt, I've tried again... And now master mode appears to be working! (needs more testing, though)

As before, I've described everything at my blog:
http://my.opera.com/CrazyTerabyte/blog/ ... de-finally

An special note to the last part of my blog post. I guess my previous attempt had failed because I had the CLIENT misconfigured. I can't really confirm this, but today I've noticed that I had some incorrect lines at wpa_supplicant.conf on my notebook, and these lines might have been the cause of failure.

_________________
http://denilson.sa.nom.br/


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 26 posts ]  Go to page Previous  1, 2

All times are UTC


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group