[rt2x00-users] [PATCH 2/4] rt2x00: Enable RT30xx by default.

Pavel Roskin proski at gnu.org
Tue May 4 06:59:18 AEST 2010


On Mon, 2010-05-03 at 22:43 +0200, Gertjan van Wingerde wrote:
> Now that RT30xx support is at the same level as RT28xx support we can enable
> these devices by default.
> 
> Signed-off-by: Gertjan van Wingerde <gwingerde at gmail.com>
> ---
>  drivers/net/wireless/rt2x00/Kconfig |    4 ++--
>  1 files changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/net/wireless/rt2x00/Kconfig b/drivers/net/wireless/rt2x00/Kconfig
> index 5239e08..eea1ef2 100644
> --- a/drivers/net/wireless/rt2x00/Kconfig
> +++ b/drivers/net/wireless/rt2x00/Kconfig
> @@ -87,7 +87,7 @@ if RT2800PCI
>  
>  config RT2800PCI_RT30XX
>  	bool "rt2800pci - Include support for rt30xx (PCI/PCIe/PCMCIA) devices"
> -	default n
> +	default y

I believe defaulting booleans to "y" is discouraged, especially for
drivers.  Most users don't have any particular hardware device.

-- 
Regards,
Pavel Roskin




More information about the users mailing list