[rt2x00-users] rt61pci using hostapd has stopped receiving packets when using WPA

Helmut Schaa helmut.schaa at googlemail.com
Fri Jan 7 21:09:24 EST 2011


Am Freitag, 7. Januar 2011 schrieb Denilson Figueiredo de Sá:
> On Thu, 06 Jan 2011 11:04:22 -0200, Helmut Schaa  
> <helmut.schaa at googlemail.com> wrote:
> > Am Donnerstag, 6. Januar 2011 schrieb Denilson Figueiredo de Sá:
> >> On Thu, 06 Jan 2011 09:01:48 -0200, Helmut Schaa
> >> <helmut.schaa at googlemail.com> wrote:
> >> > Am Donnerstag, 6. Januar 2011 schrieb Denilson Figueiredo de Sá:
> >> >
> >> >> However, this week I decided to update this kernel, and, after the
> >> >> update,
> >> >> my Wi-Fi stopped working. I've updated to linux-2.6.36-gentoo-r5.
> >> >
> >> > Could you please check if [1] fixes this issue for you?
> >> >
> >> > [1]
> >> >  
> >> http://git.kernel.org/?p=linux/kernel/git/linville/wireless-testing.git;a=commit;h=fa8b4b22d543b4052602b0c86065150613ed19e8
> >>
> >> I tried applying that patch, but I failed. Even though rt2x00mac.c  
> >> applied
> >> correctly, the rt2800lib.c file is different from what the patch  
> >> expected.
> >
> > Since you're using rt61pci just ignore the rt2800* hunks for now.
> 
> I've just applied the (small) rt2x00mac.c patch, and it seems to work.
> 
> So... People can either disable hw crypto on buggy kernel versions, or use  
> this patch to fix it, leaving hw crypto on (which should be better, I  
> guess, because it should reduce the CPU load, am I right?).

Ok, thanks. I guess it makes sense to push this patch to 2.6.36 stable then ...

Helmut



More information about the users mailing list