[rt2x00-users] Support for Ralink 5370 WiFi USB dongle

Helmut Schaa helmut.schaa at googlemail.com
Sun Oct 30 13:40:45 AEDT 2011


Hi Ingvar,

On Sat, Oct 29, 2011 at 4:22 PM, Ingvar Hagelund
<ingvar at redpill-linpro.com> wrote:
> As more or less expected, the included Linux driver did not work, so I tried the standard kernel driver rt2x00. It loaded, but was unable to detect what chip this
> was. After a bit of googling around, I tried the latest compat-wireless (that was compat-wireless-2011-10-28), but with similar results. A list post from april claimed
> that the 5370 was more or less the same as 5390, so I hacked the header files. Now the chip was detected, but it could not find correct RF ID, and bailed out with
> "Invalid RF chipset 0x105 detected". Looking a bit more closely on the driver, I found that 5370 support had been added, but had another RF ID.

Interesting, we had a similar case a while ago also with an unknown RF
chipset. I have no access to the Ralink
legacy drivers right now since I'm traveling but could you please
check if the drivers at [1] contain your RF ID
(just have a look at the file include/chip/rtmp_phy.h and look for the
RFIC_* macros).

But since you report that the ID is working as expected I have no
objection against adding it
to rt2x00 but I wouldn't remove the previous ID.

Thanks,
Helmut

[1] http://www.ralinktech.com/en/04_support/support.php?sn=501




More information about the users mailing list