[rt2x00-users] Support for Ralink 5370 WiFi USB dongle

Gertjan van Wingerde gwingerde at gmail.com
Mon Oct 31 21:15:07 AEDT 2011


On Sat, Oct 29, 2011 at 4:22 PM, Ingvar Hagelund
<ingvar at redpill-linpro.com> wrote:
> Hello, list. This is my first post :-)
>
> I recently bought a cheap "Ultra-Mini Nano USB 2.0 150Mbps 802.11b/g/n Wifi/WLAN Wireless Network Adapter" dongle, $8.10 on DealExtreme*, and plugged it into my fedora-almost-16 laptop, running some linux-3.1.0
>
> The dongle presents itself to lsusb** as "ID 148f:5370 Ralink Technology, Corp."
>
> As more or less expected, the included Linux driver did not work, so I tried the standard kernel driver rt2x00. It loaded, but was unable to detect what chip this was. After a bit of googling around, I tried the latest compat-wireless (that was compat-wireless-2011-10-28), but with similar results. A list post from april claimed that the 5370 was more or less the same as 5390, so I hacked the header files. Now the chip was detected, but it could not find correct RF ID, and bailed out with "Invalid RF chipset 0x105 detected". Looking a bit more closely on the driver, I found that 5370 support had been added, but had another RF ID.
>
> So I did a small patch (attached), stubbed some missing headers in rfkill-gpio.h (see https://lkml.org/lkml/2011/9/29/141 , I did only the headers, the driver compiled fine without the rest. I guess linux-3.1.0 is not new enough for latest compat-wireless), and voila, the driver worked with no problems, and there was a lot of rejoicing.
>
> NetworkManager manages it fine, and WPA encryption works fine, and the diode blinks happily. Seems like the NetworkManager applet signal level meter may be broken, but I don't know how this is related. With some light testing, I manage to get about 6-8Mbps through on WPA. I have not tested without encryption, and it might just be that the old USB port slows it down. I find this quite satisfactory, though a bit less than the claimed 150MBps :-)
>
> Regarding the RF ID code in the patch, I would like to know if the original code, 0x5370, was just a guess, or if there do exist at least to versions of this chip. If so, the someone has to hack a bit to support both versions.
>
> Bonus hacking points: This was done on an Apple G3 iBook, that is 32bit ppc from 2002 :-)
>
> Best regards,
> Ingvar Hagelund
>
>
> * The dongle may be found here:
> http://www.dealextreme.com/p/ultra-mini-nano-usb-2-0-150mbps-802-11b-g-n-wifi-wlan-wireless-network-adapter-white-67532

<removed lsusb output>

Could you share the output of rt2x00 with CONFIG_RT2X00_DEBUG enabled
without your patches applied?

I am wondering what the rt chipset is that is reported in the EEPROM.

---
Gertjan




More information about the users mailing list