[rt2x00-users] [bugzilla-daemon at bugzilla.kernel.org: [Bug 42828] rt2800pci unstable - chokes after too much I/O]

Andreas Hartmann andihartmann at 01019freenet.de
Fri Oct 19 07:14:46 AEDT 2012


Andreas Hartmann wrote:
> Hello Stanislaw,
> 
> Stanislaw Gruszka wrote:
>> Andreas,
>>
>> any insight on commit be03d4a45c09ee5100d3aaaedd087f19bc20d01f
>> regression described in kernel.org bug 42828 ?
> 
> He uses another chipset:
> Chipset detected - rt: 2872, rf: 0003, rev: 0200
> Firmware detected - version: 0.34
> 
> What's the name (brand) of this device?
> 
> I have:
> Chipset detected - rt: 2860, rf: 0002, rev: 0103
> Firmware detected - version: 0.34
> 
> 
> Does the problem occur with 2.4 GHz or 5 GHz? With 20 MHz or 40 MHz?
> 
> What's the AP device?
> 
> 
> Anyway, I retested with compat-wireless-3.5 rc5 and I can see a complete
> hanging connection after 3s of running netperf with
> 0011-Revert-rt2x00-Don-t-let-mac80211-send-a-BAR-when-an-.patch (2.4
> GHz, 40MHz) - the original problem and the reason for the patch.
> 
> Maybe we should distinguish between AP and STA? Or is it a device
> specific problem? I'm not sure. Helmut mentioned here that it could be a
> hardware issue, too:
> http://news.gmane.org/find-root.php?group=gmane.linux.kernel.wireless.general&article=83767
> 
> He proposed another patch, too, which unfortunately crashed my machine:
> http://thread.gmane.org/gmane.linux.kernel.wireless.general/83297/focus=84263
> .

Just found the third user, which had a problem with AP mode:
http://thread.gmane.org/gmane.linux.drivers.rt2x00.user/569/focus=703

The hardware he uses:
https://launchpadlibrarian.net/98461561/Lspci.txt

RT2800 802.11n PCI [1814:0601] -> it's exactly the same hardware I'm using.

> There was another user writing about throughput problems with an AP, too:
> http://thread.gmane.org/gmane.linux.kernel.wireless.general/85391
> 
> He seems to use a similar card to mine:
> Chipset detected - rt: 2860, rf: 0001, rev: 0101
> 
> 
> I could try to test if there is a difference in behaviour between STA
> and AP here on weekend with my device so that we know if it is a AP / STA
> related problem or a device specific one. Would this help to possibly
> locate the problem?
> 
> 
>> Date: Wed, 17 Oct 2012 22:47:11 +0000 (UTC)
>> From: bugzilla-daemon at bugzilla.kernel.org
>> To: stf_xl at wp.pl
>> Subject: [Bug 42828] rt2800pci unstable - chokes after too much I/O
>>
>> https://bugzilla.kernel.org/show_bug.cgi?id=42828
>>
>>
>>
>>
>>
>> --- Comment #34 from Francisco Pina Martins <f.pinamartins at gmail.com>  2012-10-17 22:47:11 ---
>> Thank you for your tips, it really did sped up the process.
>> I have found the culprit!
>>
>> 0011-Revert-rt2x00-Don-t-let-mac80211-send-a-BAR-when-an-.patch
>>
>> Simply reverting this commit will make the problem go away.
> 
> 
> Kind regards,
> Andreas Hartmann
> 





More information about the users mailing list