[rt2x00-users] RT5572 status (D-Link DWA-160 B2)

Gregor Larson comm002 at glarson.org
Sat Apr 6 03:23:49 AEDT 2013


On Wed, Apr 3, 2013 at 8:27 AM, LAUKENS Niels <Niels.LAUKENS at vrt.be> wrote:
> Hi,
[...]
> Apparently[1] this device has a RaLink/MediaTek RT5572 chip onboard, which
> isn't yet supported in the mainline kernel. After some snooping around, I
> found a thread[2] on this mailing list with a batch of patches to get
> support for this chipset in the kernel.
>
> I've tried to apply these patches on my kernel (non-vanilla 3.5.7.6).
> Automatically patching with git fails on about every of the 25 patches. My
> next attempt was to apply them manually. I've managed to get the kernel to
> compile, but it panics on boot, so I've been a bit too liberal in my
> adaptations.

I tried to get the patches applied to the Quantal (3.5) kernel but eventually
gave up (to many differences). I was eventually successful applying the patches
to the linux-stable 3.8.y branch as well as a Raring (3.8) kernel.
You can look at the
complete change (relative to 3.8.5) at: http://glarson.org/share/rt5592/

Are you running Quantal? I have a 3.8 kernel (binary) packages from
Raring, with the rt5592 patches, back-ported for Quantal (32 bit).
It's not a supported package, but at least you could try out your
hardware.
  - Greg
[...]




More information about the users mailing list